summaryrefslogtreecommitdiff
path: root/sys-kernel
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2009-06-15 14:55:34 +0100
committerNick White <git@njw.me.uk>2009-06-15 14:55:34 +0100
commitf4206a83b58fad970d98fa3603aa2aac3a470d66 (patch)
treec9937946c330ab72ea5a40ea7de36c1c28ecf94c /sys-kernel
parent22fe1bdc67ddad9bc6a35d24cf0b9d18bd9142b3 (diff)
downloadnjw-gentoo-local-f4206a83b58fad970d98fa3603aa2aac3a470d66.tar.bz2
njw-gentoo-local-f4206a83b58fad970d98fa3603aa2aac3a470d66.zip
Added libre gentoo-patched linux ebuild
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild46
-rw-r--r--sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild50
2 files changed, 50 insertions, 46 deletions
diff --git a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild
deleted file mode 100644
index 95e1f81..0000000
--- a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-K_SECURITY_UNSUPPORTED="1"
-ETYPE="sources"
-K_WANT_GENPATCHES="base extras"
-K_GENPATCHES_VER="6"
-inherit kernel-2
-detect_version
-
-LIBRE_URI_BASE="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre"
-DEBLOB_CHECK="deblob-check"
-
-DESCRIPTION="Full sources for the BLOB free version of the Linux kernel"
-HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/"
-SRC_URI="${LIBRE_URI_BASE}/linux-${PV}-libre.tar.bz2 ${LIBRE_URI_BASE}/${DEBLOB_CHECK} ${GENPATCHES_URI}"
-
-KEYWORDS="~amd64 x86"
-
-# use our own unpack function as tarball is laid out differently
-universal_unpack() {
- cd ${WORKDIR}
- #unpack linux-${KV_FULL}.tar.bz2
- unpack linux-2.6.29.4-libre.tar.bz2
- S=${WORKDIR}/linux-${KV_FULL}
- mv ${WORKDIR}/linux-${PV} ${WORKDIR}/linux-${KV_FULL} \
- || die "Unable to move source tree to ${KV_FULL}."
- cd ${S}
-
- # remove all backup files
- find . -iname "*~" -exec rm {} \; 2> /dev/null
-}
-
-src_unpack() {
- # patches included in tarball
- UNIPATCH_LIST_DEFAULT=""
-
- echo "Checking patches are clean of blobs"
- chmod +x "${DISTDIR}/${DEBLOB_CHECK}"
- sh ${DISTDIR}/${DEBLOB_CHECK} ${UNIPATCH_LIST_GENPATCHES}
- if [ $? -ne 0 ]; then
- echo "Warning: gentoo patches appear to contain blobs,"
- echo "please report to bugs.gentoo.org/266157"
- echo "Disabling gentoo patches for now"
- UNIPATCH_LIST_GENPATCHES=""
- fi
-
- kernel-2_src_unpack
-}
diff --git a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild
new file mode 100644
index 0000000..4e57cb8
--- /dev/null
+++ b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild
@@ -0,0 +1,50 @@
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="2"
+inherit kernel-2
+detect_version
+detect_arch
+
+LIBRE_URI_BASE="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre"
+DEBLOB_CHECK="deblob-check"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the
+${KV_MAJOR}.${KV_MINOR} BLOB free version of the Linux kernel tree"
+
+HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/
+http://dev.gentoo.org/~dsd/genpatches"
+SRC_URI="${LIBRE_URI_BASE}/linux-${PV}-libre.tar.bz2 ${LIBRE_URI_BASE}/${DEBLOB_CHECK} ${GENPATCHES_URI} ${ARCH_URI}"
+
+KEYWORDS="~x86"
+
+src_unpack() {
+ # kernel revision patches included in tarball
+ UNIPATCH_LIST_DEFAULT=""
+
+ echo "Checking patches are clean of blobs"
+ sh ${DISTDIR}/${DEBLOB_CHECK} ${UNIPATCH_LIST_GENPATCHES}
+ if [ $? -ne 0 ]; then
+ ewarn "Warning: gentoo patches appear to contain blobs,"
+ ewarn "please report to bugs.gentoo.org/266157"
+ ewarn "Disabling gentoo patches for now"
+ UNIPATCH_LIST_GENPATCHES=""
+ fi
+
+ # universal_unpack expects a different kernel tarball name
+ expected_tarball=${DISTDIR}/linux-${OKV}.tar.bz2
+
+ # temporarily move any preexisting kernel tarball
+ [[ -f $expected_tarball ]] && \
+ mv $expected_tarball ${expected_tarball}-original
+
+ ln -sf ${DISTDIR}/linux-${OKV}-libre.tar.bz2 $expected_tarball
+
+ kernel-2_src_unpack
+
+ rm $expected_tarball
+
+ # put any preexisting tarball back in its original location
+ [[ -f ${expected_tarball}-original ]] && \
+ mv ${expected_tarball}-original $expected_tarball
+}