summaryrefslogtreecommitdiff
path: root/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild')
-rw-r--r--sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild
deleted file mode 100644
index 95e1f81..0000000
--- a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-K_SECURITY_UNSUPPORTED="1"
-ETYPE="sources"
-K_WANT_GENPATCHES="base extras"
-K_GENPATCHES_VER="6"
-inherit kernel-2
-detect_version
-
-LIBRE_URI_BASE="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre"
-DEBLOB_CHECK="deblob-check"
-
-DESCRIPTION="Full sources for the BLOB free version of the Linux kernel"
-HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/"
-SRC_URI="${LIBRE_URI_BASE}/linux-${PV}-libre.tar.bz2 ${LIBRE_URI_BASE}/${DEBLOB_CHECK} ${GENPATCHES_URI}"
-
-KEYWORDS="~amd64 x86"
-
-# use our own unpack function as tarball is laid out differently
-universal_unpack() {
- cd ${WORKDIR}
- #unpack linux-${KV_FULL}.tar.bz2
- unpack linux-2.6.29.4-libre.tar.bz2
- S=${WORKDIR}/linux-${KV_FULL}
- mv ${WORKDIR}/linux-${PV} ${WORKDIR}/linux-${KV_FULL} \
- || die "Unable to move source tree to ${KV_FULL}."
- cd ${S}
-
- # remove all backup files
- find . -iname "*~" -exec rm {} \; 2> /dev/null
-}
-
-src_unpack() {
- # patches included in tarball
- UNIPATCH_LIST_DEFAULT=""
-
- echo "Checking patches are clean of blobs"
- chmod +x "${DISTDIR}/${DEBLOB_CHECK}"
- sh ${DISTDIR}/${DEBLOB_CHECK} ${UNIPATCH_LIST_GENPATCHES}
- if [ $? -ne 0 ]; then
- echo "Warning: gentoo patches appear to contain blobs,"
- echo "please report to bugs.gentoo.org/266157"
- echo "Disabling gentoo patches for now"
- UNIPATCH_LIST_GENPATCHES=""
- fi
-
- kernel-2_src_unpack
-}