summaryrefslogtreecommitdiff
path: root/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild')
-rw-r--r--sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild
new file mode 100644
index 0000000..4e57cb8
--- /dev/null
+++ b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild
@@ -0,0 +1,50 @@
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="2"
+inherit kernel-2
+detect_version
+detect_arch
+
+LIBRE_URI_BASE="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre"
+DEBLOB_CHECK="deblob-check"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the
+${KV_MAJOR}.${KV_MINOR} BLOB free version of the Linux kernel tree"
+
+HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/
+http://dev.gentoo.org/~dsd/genpatches"
+SRC_URI="${LIBRE_URI_BASE}/linux-${PV}-libre.tar.bz2 ${LIBRE_URI_BASE}/${DEBLOB_CHECK} ${GENPATCHES_URI} ${ARCH_URI}"
+
+KEYWORDS="~x86"
+
+src_unpack() {
+ # kernel revision patches included in tarball
+ UNIPATCH_LIST_DEFAULT=""
+
+ echo "Checking patches are clean of blobs"
+ sh ${DISTDIR}/${DEBLOB_CHECK} ${UNIPATCH_LIST_GENPATCHES}
+ if [ $? -ne 0 ]; then
+ ewarn "Warning: gentoo patches appear to contain blobs,"
+ ewarn "please report to bugs.gentoo.org/266157"
+ ewarn "Disabling gentoo patches for now"
+ UNIPATCH_LIST_GENPATCHES=""
+ fi
+
+ # universal_unpack expects a different kernel tarball name
+ expected_tarball=${DISTDIR}/linux-${OKV}.tar.bz2
+
+ # temporarily move any preexisting kernel tarball
+ [[ -f $expected_tarball ]] && \
+ mv $expected_tarball ${expected_tarball}-original
+
+ ln -sf ${DISTDIR}/linux-${OKV}-libre.tar.bz2 $expected_tarball
+
+ kernel-2_src_unpack
+
+ rm $expected_tarball
+
+ # put any preexisting tarball back in its original location
+ [[ -f ${expected_tarball}-original ]] && \
+ mv ${expected_tarball}-original $expected_tarball
+}