summaryrefslogtreecommitdiff
path: root/sys-kernel
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2009-06-14 19:42:51 +0100
committerNick White <git@njw.me.uk>2009-06-14 19:42:51 +0100
commitdb58686ea91f7276adbf68e9db40fba0a4112405 (patch)
treec1afdd244def5611db551bb25f9a319e7a2aa93b /sys-kernel
downloadnjw-gentoo-local-db58686ea91f7276adbf68e9db40fba0a4112405.tar.bz2
njw-gentoo-local-db58686ea91f7276adbf68e9db40fba0a4112405.zip
Initial commit
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/libre-sources/libre-sources-2.6.29.3.ebuild30
-rw-r--r--sys-kernel/libre-sources/libre-sources-2.6.29.4.ebuild30
-rw-r--r--sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild46
3 files changed, 106 insertions, 0 deletions
diff --git a/sys-kernel/libre-sources/libre-sources-2.6.29.3.ebuild b/sys-kernel/libre-sources/libre-sources-2.6.29.3.ebuild
new file mode 100644
index 0000000..6968b1c
--- /dev/null
+++ b/sys-kernel/libre-sources/libre-sources-2.6.29.3.ebuild
@@ -0,0 +1,30 @@
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the BLOB free version of the Linux kernel"
+HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/"
+SRC_URI="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre/linux-${PV}-libre.tar.bz2"
+
+KEYWORDS="~amd64 x86"
+
+# use our own unpack function as tarball is laid out differently
+universal_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${KV_FULL}.tar.bz2
+ S=${WORKDIR}/linux-${KV_FULL}
+ mv ${WORKDIR}/linux-${PV} ${WORKDIR}/linux-${KV_FULL} \
+ || die "Unable to move source tree to ${KV_FULL}."
+ cd ${S}
+
+ # remove all backup files
+ find . -iname "*~" -exec rm {} \; 2> /dev/null
+}
+
+src_unpack() {
+ # patches included in tarball
+ UNIPATCH_LIST_DEFAULT=""
+
+ kernel-2_src_unpack
+}
diff --git a/sys-kernel/libre-sources/libre-sources-2.6.29.4.ebuild b/sys-kernel/libre-sources/libre-sources-2.6.29.4.ebuild
new file mode 100644
index 0000000..6968b1c
--- /dev/null
+++ b/sys-kernel/libre-sources/libre-sources-2.6.29.4.ebuild
@@ -0,0 +1,30 @@
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the BLOB free version of the Linux kernel"
+HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/"
+SRC_URI="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre/linux-${PV}-libre.tar.bz2"
+
+KEYWORDS="~amd64 x86"
+
+# use our own unpack function as tarball is laid out differently
+universal_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${KV_FULL}.tar.bz2
+ S=${WORKDIR}/linux-${KV_FULL}
+ mv ${WORKDIR}/linux-${PV} ${WORKDIR}/linux-${KV_FULL} \
+ || die "Unable to move source tree to ${KV_FULL}."
+ cd ${S}
+
+ # remove all backup files
+ find . -iname "*~" -exec rm {} \; 2> /dev/null
+}
+
+src_unpack() {
+ # patches included in tarball
+ UNIPATCH_LIST_DEFAULT=""
+
+ kernel-2_src_unpack
+}
diff --git a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild
new file mode 100644
index 0000000..95e1f81
--- /dev/null
+++ b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.29.4.ebuild
@@ -0,0 +1,46 @@
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="6"
+inherit kernel-2
+detect_version
+
+LIBRE_URI_BASE="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre"
+DEBLOB_CHECK="deblob-check"
+
+DESCRIPTION="Full sources for the BLOB free version of the Linux kernel"
+HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/"
+SRC_URI="${LIBRE_URI_BASE}/linux-${PV}-libre.tar.bz2 ${LIBRE_URI_BASE}/${DEBLOB_CHECK} ${GENPATCHES_URI}"
+
+KEYWORDS="~amd64 x86"
+
+# use our own unpack function as tarball is laid out differently
+universal_unpack() {
+ cd ${WORKDIR}
+ #unpack linux-${KV_FULL}.tar.bz2
+ unpack linux-2.6.29.4-libre.tar.bz2
+ S=${WORKDIR}/linux-${KV_FULL}
+ mv ${WORKDIR}/linux-${PV} ${WORKDIR}/linux-${KV_FULL} \
+ || die "Unable to move source tree to ${KV_FULL}."
+ cd ${S}
+
+ # remove all backup files
+ find . -iname "*~" -exec rm {} \; 2> /dev/null
+}
+
+src_unpack() {
+ # patches included in tarball
+ UNIPATCH_LIST_DEFAULT=""
+
+ echo "Checking patches are clean of blobs"
+ chmod +x "${DISTDIR}/${DEBLOB_CHECK}"
+ sh ${DISTDIR}/${DEBLOB_CHECK} ${UNIPATCH_LIST_GENPATCHES}
+ if [ $? -ne 0 ]; then
+ echo "Warning: gentoo patches appear to contain blobs,"
+ echo "please report to bugs.gentoo.org/266157"
+ echo "Disabling gentoo patches for now"
+ UNIPATCH_LIST_GENPATCHES=""
+ fi
+
+ kernel-2_src_unpack
+}