summaryrefslogtreecommitdiff
path: root/sys-kernel
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2009-06-15 10:32:49 +0100
committerNick White <git@njw.me.uk>2009-06-15 10:32:49 +0100
commit90b25199c9fbd9669c3df0fbb97c3d8738f7a52d (patch)
tree877b0135662490d3f63f6064d176f0dc55b64d88 /sys-kernel
parent69101721d6f5962090509fb210e16fe33d47fb28 (diff)
downloadnjw-gentoo-local-90b25199c9fbd9669c3df0fbb97c3d8738f7a52d.tar.bz2
njw-gentoo-local-90b25199c9fbd9669c3df0fbb97c3d8738f7a52d.zip
Added libre-sources 2.6.30 ebuild
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/libre-sources/libre-sources-2.6.30.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild b/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild
new file mode 100644
index 0000000..6968b1c
--- /dev/null
+++ b/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild
@@ -0,0 +1,30 @@
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the BLOB free version of the Linux kernel"
+HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/"
+SRC_URI="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre/linux-${PV}-libre.tar.bz2"
+
+KEYWORDS="~amd64 x86"
+
+# use our own unpack function as tarball is laid out differently
+universal_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${KV_FULL}.tar.bz2
+ S=${WORKDIR}/linux-${KV_FULL}
+ mv ${WORKDIR}/linux-${PV} ${WORKDIR}/linux-${KV_FULL} \
+ || die "Unable to move source tree to ${KV_FULL}."
+ cd ${S}
+
+ # remove all backup files
+ find . -iname "*~" -exec rm {} \; 2> /dev/null
+}
+
+src_unpack() {
+ # patches included in tarball
+ UNIPATCH_LIST_DEFAULT=""
+
+ kernel-2_src_unpack
+}