summaryrefslogtreecommitdiff
path: root/sys-kernel
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2009-06-18 09:41:13 +0100
committerNick White <git@njw.me.uk>2009-06-18 09:41:13 +0100
commit5898fe769d039856609162036af9444a3b6e00c0 (patch)
tree57cfb9a00f9c4da4eb92f5cfc4ac1eddab83d93d /sys-kernel
parent9bb440691c035cba24c9fd7c2c8f5ded64a4cafd (diff)
downloadnjw-gentoo-local-5898fe769d039856609162036af9444a3b6e00c0.tar.bz2
njw-gentoo-local-5898fe769d039856609162036af9444a3b6e00c0.zip
Added librehardened, and allow for libre versions
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/librehardened-sources/librehardened-sources-2.6.29.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-kernel/librehardened-sources/librehardened-sources-2.6.29.ebuild b/sys-kernel/librehardened-sources/librehardened-sources-2.6.29.ebuild
new file mode 100644
index 0000000..9ac3093
--- /dev/null
+++ b/sys-kernel/librehardened-sources/librehardened-sources-2.6.29.ebuild
@@ -0,0 +1,50 @@
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="6"
+LIBRE_VER="1"
+
+inherit kernel-libre
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
+HGPV_URI="http://dev.gentoo.org/~gengor/distfiles/${CATEGORY}/${PN}/hardened-patches-${HGPV}.extras.tar.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4201_fbcondecor-0.9.6.patch"
+
+KEYWORDS="~x86"
+IUSE=""
+HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/
+http://www.gentoo.org/proj/en/hardened/"
+
+DESCRIPTION="Hardened kernel sources (blob-free kernel, series
+${KV_MAJOR}.${KV_MINOR})"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI} ${DEBLOB_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.1.14*"
+
+ ewarn
+ ewarn "As of ${CATEGORY}/${PN}-2.6.24 the predefined"
+ ewarn "\"Hardened [Gentoo]\" grsecurity level has been removed."
+ ewarn "Two improved predefined security levels replace it:"
+ ewarn "\"Hardened Gentoo [server]\" and \"Hardened Gentoo [workstation]\""
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.24,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with kernel series ${OKV}."
+ ewarn "Therefore, it is strongly recommended that the following command is"
+ ewarn "issued prior to booting a ${P} series kernel for"
+ ewarn "the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}