summaryrefslogtreecommitdiff
path: root/sys-kernel/libre-sources
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2009-06-15 17:52:16 +0100
committerNick White <git@njw.me.uk>2009-06-15 17:52:16 +0100
commit21d6c9f32d1dca6e8149cdf8169d960cca7577d8 (patch)
tree49e20a3aa20ea07f8f44ccc26ae5a2a4c10d6e82 /sys-kernel/libre-sources
parent20110ff8f47b0ee82248283224f2b15a5da9c2e8 (diff)
downloadnjw-gentoo-local-21d6c9f32d1dca6e8149cdf8169d960cca7577d8.tar.bz2
njw-gentoo-local-21d6c9f32d1dca6e8149cdf8169d960cca7577d8.zip
Use eclass to handle libre-linux ebuilds
Diffstat (limited to 'sys-kernel/libre-sources')
-rw-r--r--sys-kernel/libre-sources/libre-sources-2.6.30.ebuild27
1 files changed, 3 insertions, 24 deletions
diff --git a/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild b/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild
index 25a9ef5..dfc113c 100644
--- a/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild
+++ b/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild
@@ -1,32 +1,11 @@
K_SECURITY_UNSUPPORTED="1"
ETYPE="sources"
-inherit kernel-2
+inherit kernel-libre
detect_version
DESCRIPTION="Full sources for the BLOB free version of the Linux kernel"
HOMEPAGE="http://www.fsfla.org/svnwiki/selibre/linux-libre/"
-SRC_URI="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre/linux-${PV}-libre.tar.bz2"
+SRC_URI="${LIBREKERNEL_URI}"
KEYWORDS="~amd64 ~x86"
-
-src_unpack() {
- # kernel revision patches included in tarball
- UNIPATCH_LIST_DEFAULT=""
-
- # universal_unpack expects a different kernel tarball name
- expected_tarball=${DISTDIR}/linux-${OKV}.tar.bz2
-
- # temporarily move any preexisting kernel tarball
- [[ -f $expected_tarball ]] && \
- mv $expected_tarball ${expected_tarball}-original
-
- ln -sf ${DISTDIR}/linux-${KV_FULL}.tar.bz2 $expected_tarball
-
- kernel-2_src_unpack
-
- rm $expected_tarball
-
- # put any preexisting tarball back in its original location
- [[ -f ${expected_tarball}-original ]] && \
- mv ${expected_tarball}-original $expected_tarball
-}
+IUSE=""