summaryrefslogtreecommitdiff
path: root/games-engines/gemrb/gemrb-0.3.1.ebuild
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2009-06-14 19:42:51 +0100
committerNick White <git@njw.me.uk>2009-06-14 19:42:51 +0100
commitdb58686ea91f7276adbf68e9db40fba0a4112405 (patch)
treec1afdd244def5611db551bb25f9a319e7a2aa93b /games-engines/gemrb/gemrb-0.3.1.ebuild
downloadnjw-gentoo-local-db58686ea91f7276adbf68e9db40fba0a4112405.tar.bz2
njw-gentoo-local-db58686ea91f7276adbf68e9db40fba0a4112405.zip
Initial commit
Diffstat (limited to 'games-engines/gemrb/gemrb-0.3.1.ebuild')
-rw-r--r--games-engines/gemrb/gemrb-0.3.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-engines/gemrb/gemrb-0.3.1.ebuild b/games-engines/gemrb/gemrb-0.3.1.ebuild
new file mode 100644
index 0000000..d70ae34
--- /dev/null
+++ b/games-engines/gemrb/gemrb-0.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools eutils games
+
+DESCRIPTION="Reimplementation of the Infinity engine"
+HOMEPAGE="http://gemrb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=media-libs/libsdl-1.2
+ media-libs/openal
+ >=dev-lang/python-2.3"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's/AM_PATH_OPENAL(\[\], /AC_CHECK_HEADER(AL\/al.h,,/' \
+ configure.in || die "fix openal detection failed"
+ sed -i "s/OPENAL_LIBS=\"\`openal-config --libs\`\"/OPENAL_LIBS=\"-lopenal\"/" \
+ configure.in || die "fix openal detection failed"
+ sed -i 's|\$(bindir)/plugins/|\$(libdir)/|' \
+ Makefile.am || die "move plugindir failed"
+ sed -i '/sysconf_DATA = GemRB.cfg.sample GemRB.cfg.subdir.sample/d' \
+ gemrb/Makefile.am || die "remove default config failed"
+ if ! use doc ; then
+ sed -i 's|^SUBDIRS = \(.*\) docs|SUBDIRS = \1|' \
+ gemrb/Makefile.am || die "don't install docs failed"
+ fi
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ egamesconf \
+ --docdir="/usr/share/doc/${PF}" \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ libtool --finish "${GAMES_LIBDIR}"
+ diropts -m0775 -g ${GAMES_GROUP}
+ keepdir "/var/cache/gemrb"
+ dodoc "${FILESDIR}/GemRB.cfg.sample"
+ dodoc README AUTHORS
+ prepgamesdirs
+}