summaryrefslogtreecommitdiff
path: root/dev-games/renpy-modules
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2010-04-18 17:11:33 +0100
committerNick White <git@njw.me.uk>2010-04-18 17:11:33 +0100
commitde4d001f691e07f972fd512e3f1cc0b9bafab853 (patch)
tree4f556c0bbbaefe6bd6f8a00e121c28286dbd3749 /dev-games/renpy-modules
parent5833df9fd700f7734b11035ef54c8e0f7165c0b3 (diff)
downloadnjw-gentoo-local-de4d001f691e07f972fd512e3f1cc0b9bafab853.tar.bz2
njw-gentoo-local-de4d001f691e07f972fd512e3f1cc0b9bafab853.zip
Add ebuild for digital (and copies of renpy dep)
Diffstat (limited to 'dev-games/renpy-modules')
-rw-r--r--dev-games/renpy-modules/renpy-modules-6.10.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-games/renpy-modules/renpy-modules-6.10.2.ebuild b/dev-games/renpy-modules/renpy-modules-6.10.2.ebuild
new file mode 100644
index 0000000..49c2d72
--- /dev/null
+++ b/dev-games/renpy-modules/renpy-modules-6.10.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils eutils
+
+MY_P=${PN%-modules}-${PV}
+PYTHON_MODNAME="pysdlsound"
+
+DESCRIPTION="Modules for renpy"
+HOMEPAGE="http://www.renpy.org"
+SRC_URI="http://www.renpy.org/dl/${PV}/${MY_P}-source.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ media-libs/libsdl
+ media-libs/freetype:2
+ media-video/ffmpeg
+ dev-libs/fribidi
+ dev-python/pygame[X]
+ sys-libs/zlib
+ !=dev-games/renpy-6.10.2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/module"
+
+# RENPY_DEPS_INSTALL is a double-colon separated list of directories that
+# contains all core renpy dependencies. This is usually /usr.
+export RENPY_DEPS_INSTALL="${ROOT}usr"