summaryrefslogtreecommitdiff
path: root/app-text/pdftk/pdftk-1.41-r2.ebuild
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2010-03-29 04:08:10 +0100
committerNick White <git@njw.me.uk>2010-03-29 04:08:10 +0100
commit5833df9fd700f7734b11035ef54c8e0f7165c0b3 (patch)
tree0919e5644fe08e39e668911c2f9c014010812408 /app-text/pdftk/pdftk-1.41-r2.ebuild
parent78329bbadd17a3e94616e8f68a990fed48158370 (diff)
downloadnjw-gentoo-local-5833df9fd700f7734b11035ef54c8e0f7165c0b3.tar.bz2
njw-gentoo-local-5833df9fd700f7734b11035ef54c8e0f7165c0b3.zip
Add patched pdftk ebuild
Diffstat (limited to 'app-text/pdftk/pdftk-1.41-r2.ebuild')
-rw-r--r--app-text/pdftk/pdftk-1.41-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/pdftk/pdftk-1.41-r2.ebuild b/app-text/pdftk/pdftk-1.41-r2.ebuild
new file mode 100644
index 0000000..267fe45
--- /dev/null
+++ b/app-text/pdftk/pdftk-1.41-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/pdftk-1.41-r1.ebuild,v 1.1 2008/12/26 21:44:37 caster Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A tool for manipulating PDF documents"
+HOMEPAGE="http://www.pdfhacks.com/pdftk"
+SRC_URI="http://www.pdfhacks.com/pdftk/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND=">=sys-devel/gcc-4.3.1[gcj]"
+
+S="${WORKDIR}/${P}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/pdftk-1.41-r2.patch"
+
+}
+
+src_compile() {
+ # java-config settings break compilation by gcj.
+ unset CLASSPATH
+ unset JAVA_HOME
+ # parallel make fails
+ emake -j1 -f Makefile.Generic || die "Compilation failed."
+}
+
+src_install() {
+ dobin pdftk
+ newman ../debian/pdftk.1 pdftk.1
+ dohtml ../pdftk.1.html
+}