summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick White <arch@njw.me.uk>2007-05-03 00:31:22 +0000
committerNick White <arch@njw.me.uk>2007-05-03 00:31:22 +0000
commitf811c2d4823f95d7e90f25e0e7a98e5c5abcf3e2 (patch)
tree190283d4cf1efdd3ae5ba8ecaa0b6c5b5837bec9 /configure.in
parent1edf37e3b0ad7b0556ba0902b5880044933ced66 (diff)
Added Autotools, changed dir structure, added docs
Added (perhaps somewhat shaky) autotools support Added tagging rules to junkify files generated by autotools Added a directory structure Updated README & INSTALL files to reflect changes Wrote a man page Changed version numbers in preparation for a release git-archimport-id: getht@sv.gnu.org/getht--mainline--0.1--patch-23
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in47
1 files changed, 47 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..306a49b
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,47 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.61)
+AC_INIT(getht, 0.0.1)
+AC_CONFIG_SRCDIR([src/])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME,AC_PACKAGE_VERSION)
+AC_LANG([C])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+
+# Checks for libraries.
+
+dnl check for zlib
+CHECK_ZLIB()
+
+dnl check for libxml2
+AM_PATH_XML2([2.0.0])
+CFLAGS="$CFLAGS $XML_CPPFLAGS"
+LIBS="$LIBS $XML_LIBS"
+
+dnl check for libcurl
+LIBCURL_CHECK_CONFIG([yes], [7.7.2])
+CFLAGS="$CFLAGS $LIBCURL_CPPFLAGS"
+LIBS="$LIBS $LIBCURL"
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdlib.h string.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([mkdir strdup])
+
+AC_CONFIG_FILES([Makefile
+ doc/Makefile
+ src/Makefile])
+AC_OUTPUT