summaryrefslogtreecommitdiff
path: root/sys-kernel/librert-sources/librert-sources-2.6.31.4-r14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/librert-sources/librert-sources-2.6.31.4-r14.ebuild')
-rw-r--r--sys-kernel/librert-sources/librert-sources-2.6.31.4-r14.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-kernel/librert-sources/librert-sources-2.6.31.4-r14.ebuild b/sys-kernel/librert-sources/librert-sources-2.6.31.4-r14.ebuild
new file mode 100644
index 0000000..9a18cef
--- /dev/null
+++ b/sys-kernel/librert-sources/librert-sources-2.6.31.4-r14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+
+K_SECURITY_UNSUPPORTED="1"
+LIBRE_VER=1
+
+SKIP_PATCH_DEBLOB="1"
+
+ETYPE="sources"
+inherit kernel-libre
+detect_version
+
+RT_PATCH="patch-${KV/libre/}.bz2"
+
+RESTRICT="mirror"
+DESCRIPTION="Realtimne Preemption patched low latency Libre Linux kernel"
+SRC_URI="${KERNEL_URI} ${DEBLOB_URI}
+http://www.kernel.org/pub/linux/kernel/projects/rt/${RT_PATCH}"
+DEPEND="dev-util/patchutils" # to filter out unneeded changes from patch
+
+KEYWORDS="~x86"
+IUSE=""
+
+pkg_setup(){
+ # Don't change EXTRAVERSION info
+ filterdiff -zx 'a/Makefile' "${DISTDIR}/${RT_PATCH}" \
+ | bzip2 -c > "${T}/${RT_PATCH}"
+
+ UNIPATCH_LIST="${T}/${RT_PATCH}"
+}
+
+K_EXTRAEINFO="Recommended other packages: sys-process/rtirq and sys-apps/das_watchdog"