summaryrefslogtreecommitdiff
path: root/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild')
-rw-r--r--media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild b/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild
deleted file mode 100644
index afecff9..0000000
--- a/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild,v 1.1 2009/03/31 21:26:12 patrick Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="A simple converter to create Ogg Theora files."
-HOMEPAGE="http://www.v2v.cc/~j/ffmpeg2theora/index.html"
-SRC_URI="http://www.v2v.cc/~j/ffmpeg2theora/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="kate"
-
-RDEPEND="
- || ( <media-video/ffmpeg-9999[vhook]
- >=media-video/ffmpeg-9999 )
- >=media-libs/libvorbis-1.1
- >=media-libs/libogg-1.1
- >=media-libs/libtheora-1.0_beta1[encode]
- kate? ( media-libs/libkate )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=dev-util/scons-1.0.0"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/libkate.patch"
-}
-
-src_compile() {
- myconf=""
- use kate || myconf="${myconf} libkate=no"
- scons APPEND_CFLAGS="${CFLAGS}" APPEND_LINKFLAGS="${LDFLAGS}" ${myconf} || die "scons failed"
-}
-
-src_install() {
- scons destdir="${D}" prefix=/usr mandir=PREFIX/share/man ${myconf} install || die "install failed"
- dodoc AUTHORS ChangeLog README TODO || die
-}