summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/kernel-libre.eclass13
-rw-r--r--sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild4
2 files changed, 11 insertions, 6 deletions
diff --git a/eclass/kernel-libre.eclass b/eclass/kernel-libre.eclass
index 4e7dbc0..a042ab1 100644
--- a/eclass/kernel-libre.eclass
+++ b/eclass/kernel-libre.eclass
@@ -8,12 +8,15 @@
#
inherit kernel-2
-EXPORT_FUNCTIONS src_unpack
+EXPORT_FUNCTIONS pkg_setup src_unpack
-DEBLOB_CHECK="deblob-check"
-LIBRE_URI_BASE="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre"
-LIBREKERNEL_URI="${LIBRE_URI_BASE}/linux-${PV}-libre.tar.bz2"
-DEBLOB_URI="${LIBRE_URI_BASE}/${DEBLOB_CHECK}"
+kernel-libre_pkg_setup() {
+ libre_uri_base="http://www.linux-libre.fsfla.org/pub/linux-libre/releases/${PV}-libre"
+
+ DEBLOB_CHECK="deblob-check"
+ KERNEL_URI="${LIBRE_URI_BASE}/linux-${PV}-libre.tar.bz2"
+ DEBLOB_URI="${LIBRE_URI_BASE}/${DEBLOB_CHECK}"
+}
kernel-libre_src_unpack() {
# kernel revision patches included in tarball
diff --git a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild
index d0f8ddf..9c12530 100644
--- a/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild
+++ b/sys-kernel/libregentoo-sources/libregentoo-sources-2.6.30-r1.ebuild
@@ -13,4 +13,6 @@ http://dev.gentoo.org/~dsd/genpatches"
DESCRIPTION="Full sources including the Gentoo patchset for the
${KV_MAJOR}.${KV_MINOR} blob free version of the Linux kernel tree"
-SRC_URI="${LIBREKERNEL_URI} ${DEBLOB_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${DEBLOB_URI}"
+
+# TODO: check patches with deblob script (do this in eclass)