summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/libre-sources/libre-sources-2.6.30.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild b/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild
index 011d101..23d1a4c 100644
--- a/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild
+++ b/sys-kernel/libre-sources/libre-sources-2.6.30.ebuild
@@ -14,7 +14,19 @@ src_unpack() {
UNIPATCH_LIST_DEFAULT=""
# universal_unpack expects a different kernel tarball name
- ln -sf ${WORKDIR}/linux-${KV_FULL}.tar.bz2 ${WORKDIR}/linux-${OKV}.tar.bz2
+ expected_tarball=${DISTDIR}/linux-${OKV}.tar.bz2
+
+ # temporarily move any preexisting kernel tarball
+ [[ -f $expected_tarball ]] && \
+ mv $expected_tarball ${expected_tarball}-original
+
+ ln -sf ${DISTDIR}/linux-${KV_FULL}.tar.bz2 $expected_tarball
kernel-2_src_unpack
+
+ rm $expected_tarball
+
+ # put any preexisting tarball back in its original location
+ [[ -f ${expected_tarball}-original ]] && \
+ mv ${expected_tarball}-original $expected_tarball
}