summaryrefslogtreecommitdiff
path: root/www-client/icecat
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2009-08-06 10:50:46 +0100
committerNick White <git@njw.me.uk>2009-08-06 10:50:46 +0100
commit413f68dbbc9012c66a278eac312a7971c607cb2c (patch)
tree0e51f55e9f6af8a1144184a4624052bf374d7c23 /www-client/icecat
parent17587481ee109ebbe5de76c710c0344765544924 (diff)
downloadnjw-gentoo-local-413f68dbbc9012c66a278eac312a7971c607cb2c.tar.bz2
njw-gentoo-local-413f68dbbc9012c66a278eac312a7971c607cb2c.zip
Fix branding when language packs are used
Diffstat (limited to 'www-client/icecat')
-rw-r--r--www-client/icecat/icecat-3.5.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/www-client/icecat/icecat-3.5.1.ebuild b/www-client/icecat/icecat-3.5.1.ebuild
index b0c8189..d55d10f 100644
--- a/www-client/icecat/icecat-3.5.1.ebuild
+++ b/www-client/icecat/icecat-3.5.1.ebuild
@@ -118,6 +118,27 @@ src_prepare() {
# Fix preferences location
sed -i 's|defaults/pref/|defaults/preferences/|' browser/installer/packages-static || die "sed failed"
+ for X in ${linguas}; do
+ # replace any linguas-provided branding with official branding
+ if [ ${X} != "en" ]; then
+ cd "${WORKDIR}"/${FIREFOX_P}-${X}/chrome/
+ unzip -q ${X}.jar
+
+ # Ensure branding is copied directly from icecat
+ cp "${S}"/browser/branding/unofficial/brand\.* locale/branding/
+
+ # Any variable being set should be changed
+ find . -type f -exec sed -i 's/\(.*=.*\)Firefox/\1IceCat/g' {} \;
+
+ rm ${X}.jar
+ zip -q -r ${X}.jar .
+
+ rm -r locale/
+
+ cd "${S}"
+ fi
+ done
+
# Apply our patches
EPATCH_SUFFIX="patch" \
EPATCH_FORCE="yes" \