summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2009-06-27 16:44:44 +0100
committerNick White <git@njw.me.uk>2009-06-27 16:44:44 +0100
commitc51c20599875907ce50c35b1008082f41f464ef0 (patch)
tree5b3c8d3a0f100d3366aa4785c86267d42ea78931 /net-misc
parenta9bf340ec03137341af56f8a1191298ca0262cfe (diff)
downloadnjw-gentoo-local-c51c20599875907ce50c35b1008082f41f464ef0.tar.bz2
njw-gentoo-local-c51c20599875907ce50c35b1008082f41f464ef0.zip
Remove patched dhcpcd, as newer version has conf option for this
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.13.ebuild97
-rw-r--r--net-misc/dhcpcd/files/dontmindserverid.patch14
2 files changed, 0 insertions, 111 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.13.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.13.ebuild
deleted file mode 100644
index 73166ba..0000000
--- a/net-misc/dhcpcd/dhcpcd-4.0.13.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.13.ebuild,v 1.8 2009/05/31 13:29:47 ranger Exp $
-
-EAPI=1
-
-inherit toolchain-funcs eutils
-
-MY_P="${P/_alpha/-alpha}"
-MY_P="${MY_P/_beta/-beta}"
-MY_P="${MY_P/_rc/-rc}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="http://roy.marples.name/projects/dhcpcd"
-SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.bz2"
-LICENSE="BSD-2"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-
-SLOT="0"
-IUSE="+compat zeroconf"
-
-DEPEND=""
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/dontmindserverid.patch"
-
- if ! use zeroconf; then
- elog "Disabling zeroconf support"
- {
- echo
- echo "# dhcpcd ebuild requested no zeroconf"
- echo "noipv4ll"
- } >> dhcpcd.conf
- fi
-
- if use compat; then
- elog "dhcpcd-3 command line support enabled"
- {
- echo
- echo "/* User indicated command line compatability */"
- echo "#define CMDLINE_COMPAT"
- } >> config.h
- fi
-}
-
-pkg_setup() {
- MAKE_ARGS="DBDIR=/var/lib/dhcpcd LIBEXECDIR=/lib/dhcpcd"
-}
-
-src_compile() {
- [ -z "${MAKE_ARGS}" ] && die "MAKE_ARGS is empty"
- emake CC="$(tc-getCC)" ${MAKE_ARGS} || die
-}
-
-src_install() {
- local hooks="50-ntp.conf"
- use elibc_glibc && hooks="${hooks} 50-yp.conf"
- use compat && hooks="${hooks} 50-dhcpcd-compat"
- emake ${MAKE_ARGS} HOOKSCRIPTS="${hooks}" DESTDIR="${D}" install || die
-}
-
-pkg_postinst() {
- # Upgrade the duid file to the new format if needed
- local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
- local new_duid="${ROOT}"/etc/dhcpcd.duid
- if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
- sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
- fi
-
- # Move the duid to /etc, a more sensible location
- if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
- cp -p "${old_duid}" "${new_duid}"
- fi
-
- if use zeroconf; then
- elog "You have installed dhcpcd with zeroconf support."
- elog "This means that it will always obtain an IP address even if no"
- elog "DHCP server can be contacted, which will break any existing"
- elog "failover support you may have configured in your net configuration."
- elog "This behaviour can be controlled with the -L flag."
- elog "See the dhcpcd man page for more details."
- fi
- if ! use compat; then
- elog
- elog "dhcpcd no longer sends a default ClientID for ethernet interfaces."
- elog "This is so we can re-use the address the kernel DHCP client found."
- elog "To retain the old behaviour of sending a default ClientID based on the"
- elog "hardware address for interface, simply add the keyword clientid"
- elog "to dhcpcd.conf or use commandline parameter -I ''"
- fi
-}
diff --git a/net-misc/dhcpcd/files/dontmindserverid.patch b/net-misc/dhcpcd/files/dontmindserverid.patch
deleted file mode 100644
index ecd6751..0000000
--- a/net-misc/dhcpcd/files/dontmindserverid.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- client.c 2009-04-17 20:20:40.000000000 +0100
-+++ client.c.new 2009-06-15 16:22:24.621453203 +0100
-@@ -1392,11 +1392,6 @@ handle_dhcp(struct if_state *state, stru
- logger(LOG_ERR, "ignoring message; no DHCP type");
- return 0;
- }
-- /* Every DHCP message should include ServerID */
-- if (get_option_addr(&addr.s_addr, dhcp, DHO_SERVERID) == -1) {
-- logger(LOG_ERR, "ignoring message; no Server ID");
-- return 0;
-- }
-
- /* Ensure that it's not from a blacklisted server.
- * We should expand this to check IP and/or hardware address